showandtelllogo.jpg

Recently, I was installing the Domino 9.0 Social Edition on a new CentOS 6 Linux install. It started very smoothly, the CentOS install went very well and the system updates worked flawlessly.  I prepped the notes user and group and was ready to install the Domino code.

Then it came to a screeching stop.

The installer stopped with the message below:


To run this installer you need 32bit (i686) packages installed on your 64 bit Linux Redhat.

They are not installed by default, but are mandatory. The installer will exit after this message.
glibc-2.12-1.17.el6.i686
libgcc-4.4.4-13.el6.i686
libXtst-1.0.99.2-3.el6.i686
libXmu-1.0.5-1.el6.i686
libXp-1.0.0-15.1.el6.i686
libXft-2.1.13-4.1.el6.i686
libXi-1.3-3.el6.i686
libstdc++-4.4.4-13.el6.i686


Notice, I'm installing 64bit Domino on 64bit CentOS and the installer is still a 32bit application. Also, the version numbers mentioned are old and not the latest. Trying to run the yum install for these exact versions failed.  After some searching, I had two options. First, download the RPM from a site and run the rpm installer. Second, I could try to install the most recent version and try that.

I ended up going for the second option after I backed into an install option for the latest version. Basically, leave the version info out and just use the package name and architecture version to find the current version available and install it. For example, below is the command to get te glibc package installed.


yum install -y glibc.i686


Lather, rinse, and repeat for the other packages and I was ready to go. The installer worked fine and Domino is up and running on a test VM.


BTW - For a very good walk through of the process, check out Devin Olson's YouTube videos on installing CentOS 6, Domino and Traveler. Here's the first one on installing CentOS  They're well done - and that's not just cuz I would like a beer!

Donate to support Cystic Fibrosis research for a cure

comments powered by Disqus